Ergebnis 1 bis 12 von 12

Thema: (Kleines) Problem mit Umlauten

  1. #1

    (Kleines) Problem mit Umlauten

    Hallo,

    ich habe im SpyderForum ein kleines Problem mit Umlauten. Im Prinzip werden die Umlaute korrekt dargestellt, mit ein paar Ausnahmen:

    1. In den Hilfefenstern werden die Umlaute nicht korrekt angezeigt, aber bei den jeweiligen Einstellungen schon

    Umlaute.PNG

    2. Anzeigen im Backend

    Backend.PNG

    3. In E-Mails

    E-Mail.PNG

    Die Spracheinstellung sollten eigentlich stimmen:

    Sprache.PNG

    Hat jemand vielleicht einen Tipp für mich?

    Danke schön!

    Grüße,
    Alex

  2. #2
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    44
    Beiträge
    16.446
    Blog-Einträge
    5
    1. In den Hilfefenstern
    Im Sprachpaket UTF-8 findest du auch die Adminhilfe. Diese müsstet du neu importieren.
    Das geht über Administrator-Kontrollzentrum -> vBulletin-Einstellungen -> Adminhilfe verwalten -> [Adminhilfe hochladen / herunterladen]


    2. Anzeigen im Backend
    includes/vbulletin_credits.php in UTF-8 umwandeln.


    3. In E-Mails
    Versuch mal in den Einstellungen zu E-Mail-Funktionen die Einstellung E-Mails UTF-8-kodiert senden zu aktivieren.

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vB.org!

  3. #3
    zu 1. Entweder bin ich blind, oder diesen Punkt gibt es bei mir nicht im Bereich vBulletin-Einstellungen?!

    Gruß,
    Alex

  4. #4
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    58
    Beiträge
    13.570
    Der Punkt ist mir auch nicht bekannt und nach kurzer Suche finde ich ihn auch selbst in "aktuellen" Versionen (ab 4.2.3) nicht.

    Es sollte aber eigentlich auch ganz normal über die Sprachenverwaltung (die dafür gedacht ist) gehen:
    Sprachen & Phrasen -> Sprachen verwalten -> Sprachen herunterladen/hochladen -> XML-Sprachdatei importieren

    Ansonsten schau mal, ob Du die Datei "/install/ vbulletin-adminhelp.xml" in Deinem Paket hast. Die sollte sich eigentlich als XML ganz normal auch importieren lassen (habe ich nie versucht, da nie benötigt).
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  5. #5
    Haha, ich hab's gefunden: Debug-Mode heißt des Rätzels Lösung! Nachdem dieser aktiviert wird, ist dieser Menüpunkt "Adminhilfe verwalten" verfügbar!

    Gruß,
    Alex

  6. #6
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    58
    Beiträge
    13.570
    Ach guck, an den hätte ich jetzt in dem Zusammenhang überhaupt nicht gedacht.
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  7. #7
    So, Problem 1 und 2 sind gelöst! Vielen Dank! Bleibt noch Problem 3. Die empfohlenen Einstellungen wurden bereits gemacht - ohne Erfolg!

    Hier ein Auszug aus dem E-Mail Quelltext:

    Date: Mon, 29 Apr 2019 07:26:06 +0000To: barbarossa@spyderforum.de
    From: =?UTF-8?q?Can-Am_On-Road_Forum_f=C3=83=C2=BCr_Spyder_=26_Ryker?=
    <webmaster@spyderforum.de>
    Auto-Submitted: auto-generated
    Message-ID: <20190429072606.13225fdc81e6@www.spyderforum.de>
    MIME-Version: 1.0
    Content-Type: text/plain; charset="UTF-8"
    Content-Transfer-Encoding: 8bit
    X-Priority: 3
    X-Mailer: vBulletin Mail via PHP
    Subject: =?UTF-8?q?Neuer_Benutzer_bei_Can-Am_On-Road_Forum_f=C3=BCr_Spyder_=26_Ryker?=
    X-PPP-Message-ID: <20190429072607.2375.5485@mx2f3e.netcup.net> X-PPP-Vhost: spyderforum.de
    In der Zeile "From:" haben sich die Sonderzeichen 0x83 und 0xC2 dazugemogelt! Das führt dann zu dieser merkwürdigen Darstellung. Der Zeichensatz ist jedoch anscheinend korrekt. Interessanterweise ist der Fehler in der "Subject:" Zeile nicht zu sehen; diese wird auch korrekt dargestellt!

    Da liegt doch die Vermutung nahe, dass da irgendetwas im vB-Quellcode nicht korrekt behandelt wird?!

    Nachtrag: Könnte es ggf. an der Datei /includes/class_mail.php liegen?

    Gruß,
    Alex
    Geändert von Barbarossa (29.04.2019 um 21:39 Uhr) Grund: Nachtrag

  8. #8
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    44
    Beiträge
    16.446
    Blog-Einträge
    5
    Simpelste Lösung....gib deinem Forum einen Namen ohne Umlaute.

    Zur Sicherheit...speicher nochmal die Einstellungen Homepage-Titel / URL / Kontaktinfos.
    Ruf die Seite am besten direkt auf:
    admincp/options.php?do=options&dogroup=address
    Überprüf dann im Quelltext, ob sie auch in UTF-8 angezeigt wird. Nicht, dass du im Administrator-Kontrollzentrum warum auch immer eine Sprache nutzt, die ISO-8859-1 als Zeichensatz verwendet.


    Ansonsten muss vielleicht wirklich in der class_mail.php die Variable $mailfromname bzw. $vbulletin->options['bbtitle'] behandelt werden, damit die Umlaute stimmen.


    Kannst du vielleicht mal in den Einstellungen Homepage-Titel / URL / Kontaktinfos bei Betreffauswahl für den Kontaktlink diesen Eintrag hinzufügen:
    {pogo@vbulletin-germany.com} Test

    Dann kann ich mir selbst eine E-Mail über das Kontaktformular schicken. Vielleicht seh ich dann ja irgendwas neues.

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vB.org!

  9. #9
    ... Überprüf dann im Quelltext, ob sie auch in UTF-8 angezeigt wird. Nicht, dass du im Administrator-Kontrollzentrum warum auch immer eine Sprache nutzt, die ISO-8859-1 als Zeichensatz verwendet.
    Sollte passen:

    Forum.jpg

    Kannst du vielleicht mal in den Einstellungen Homepage-Titel / URL / Kontaktinfos bei Betreffauswahl für den Kontaktlink diesen Eintrag hinzufügen:
    {pogo@vbulletin-germany.com} Test
    Ist auch erledigt ...

    Gruß,
    Alex

  10. #10
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    58
    Beiträge
    13.570
    Zitat Zitat von Barbarossa Beitrag anzeigen
    Sollte passen:

    Forum.jpg

    Sagt nur bedingt etwas aus an der Stelle. Zur Sicherheit würde ich mir trotzdem mal den "echten" Quelltext anschauen (Rechtsklick -> "Quelltext (anzeigen)" im Kontextmenü), also nachdem die Seite ausgeliefert und im Browser (resp. E-Mail Client) angezeigt wird.

    Das geht auch in Mail Clients bei HTML-Mails, indem man sich komplette Header anzeigen lässt.
    Dort findest Du u.a. auch einen Eintrag wie:
    Content-Type: text/plain; charset=iso-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit

    oder ähnlich. Das ist dann wirklich aussagekräftig und beweist, wie die Mail kodiert/dekodiert wurde.
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  11. #11
    Hallo Jörg,

    das sieht aber auch OK aus?!

    E-Mail-Quellcode.PNG

    Dann muss ich wahrscheinlich doch mal Hand an die Datei /includes/class_mail.php legen?!

    Gruß,
    Alex

  12. #12
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    58
    Beiträge
    13.570
    Hallo Alex,

    ja, passt soweit.

    Zitat Zitat von Barbarossa Beitrag anzeigen
    Dann muss ich wahrscheinlich doch mal Hand an die Datei /includes/class_mail.php legen?!
    Zumindest ansehen bzw. gegen das Original aus dem vB-Paket austauschen, ja. Evtl. wurde die Datei bei euch ja mal verändert.
    Ansonsten würde ich zur Sicherheit auch mal prüfen, ob irgendein Add-on Richtung E-Mails eingreift, auch wenn das eher unwahrscheinlich ist.
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Umzug, Update => Problem mit Umlauten
    Von TLA im Forum vBulletin 3.6 Fragen und Probleme
    Antworten: 5
    Letzter Beitrag: 30.01.2017, 12:58
  2. Forum - Problem mit Umlauten
    Von merkelc im Forum vBulletin 4 Fragen und Probleme
    Antworten: 5
    Letzter Beitrag: 10.08.2012, 11:36
  3. Forum - Problem mit Umlauten in alten Beiträgen
    Von stefand im Forum vBulletin 4 Fragen und Probleme
    Antworten: 1
    Letzter Beitrag: 20.11.2011, 12:52
  4. WBB 2.3.6 --> vB 3.8, ImpEx Import, Problem mit Umlauten
    Von rubstudent im Forum vBulletin 3.8 Installation und Upgrades
    Antworten: 12
    Letzter Beitrag: 10.08.2009, 14:17
  5. Problem mit Umlauten
    Von ChiLLouT im Forum vBulletin 3.6 Fragen und Probleme
    Antworten: 5
    Letzter Beitrag: 27.03.2008, 20:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •