PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Reeboot ??



Smoker
06.02.2005, 06:54
Ich kann meinen Server nicht mehr neu starten, weil ne Datei oder 2 fehlen.

Ich gebe wie immer ein ...

/etc/init.d/apache2 restart

Dann kommt als meldung das hier ...

[Sun Feb 06 07:51:46 2005] [warn] NameVirtualHost 62.75.224.71:80 has no VirtualHosts
Syntax OK
Found stale pidfile (unclean shutdown?). Running /usr/share/apache2/ssl_scache_cleanup
awk: cmd. line:2: fatal: cannot open file `/etc/apache2/conf.d/apache2-manual?conf' for reading (No such file or directory)
awk: cmd. line:2: fatal: cannot open file `/etc/apache2/vhosts.d/*.conf' for reading (No such file or directory)
awk: cmd. line:1: (FILENAME=/etc/apache2/conf.d/tomcat_jk.conf FNR=29) fatal: cannot open file `/etc/apache2/conf.d/apache2-manual?conf' for reading (No such file or directory)
Starting httpd2 (prefork)

Wie bekomme ich das wieder hin ?

Thxx
Smoker

Reimer
06.02.2005, 09:40
Erstelle erstmal leere Dateien mit VI:

[code]
vi /etc/apache2/conf.d/apache2-manual?conf
vi /etc/apache2/vhosts.d/test.conf #Notfalls ordner erstelen
vi /etc/apache2/conf.d/tomcat_jk.conf
/etc/init.d/apache2 restart
[code]

Hast du Tomcat installiert und wenn, wieso?

Smoker
06.02.2005, 09:51
Hast du Tomcat installiert und wenn, wieso?

Keine Ahnung.
War eventuell schon drauf, als ich den Server bei S4Y bekommen habe ( Root Server ).

Die anderen Files habe ich jetzt leer erstellt.
Die datei ( tomcat_jk.conf ) gab es schon, deswegen habe ich diese Natürlich nicht überschrieben.

Wenn ich jetzt neu starte kommt das ...


[Sun Feb 06 10:49:53 2005] [warn] NameVirtualHost 62.75.224.71:80 has no VirtualHosts
Syntax OK
Found stale pidfile (unclean shutdown?). Running /usr/share/apache2/ssl_scache_cleanup
Starting httpd2 (prefork) done

bye
Smoker

Reimer
06.02.2005, 12:39
Mit ps -aux alle Prozesse anzeigen und die mit httpd killen durch den Befehl kill PID (Die PID siehst du beim ersten Befehl). Danach neustarten. Womöglich ist da noch ein alter Prozessor irgendwo.

simplex
06.02.2005, 12:51
Mit ps -aux alle Prozesse anzeigen und die mit httpd killen durch den Befehl kill PID (Die PID siehst du beim ersten Befehl). Danach neustarten. Womöglich ist da noch ein alter Prozessor irgendwo.

Alternativ-Vorschlag
/etc/init.d/apache2 stop
ps -aux | grep httpd2
[hier die killbefehle]
/etc/init.d/apache2 start

mit dem grep ist es ein wenig übersichtlicher. evtl. auch killall httpd2

Holger
06.02.2005, 14:52
schau mal in /etc/apache2/sites-available ist da die default drinne? und wenn ja steht in der auch was ?

mfg

Smoker
06.02.2005, 15:08
schau mal in /etc/apache2/sites-available

sites-available gibt es bei mir garnicht.

bye
Smoker

Holger
06.02.2005, 15:16
dann schau mal nach ob es in der /etc/apache2/apach2.conf ein include dafür gibt
ich denke mal oder hoffe das suse da nicht wieder eigene suppe kocht

mfg

Smoker
06.02.2005, 15:16
@simplex & Reimer

Das hats gebracht.
Jetzt gehts wieder ganz normal :)
Natürlich nicht ohne deine Hilfe beim erstellen der Dateien die weg waren.

Es waren Millionen httpd Prozesse offen, deswegen warscheionlich mein RAM auch auf 98% voll :D

Ich habe nur den httpd Prozess von user ( root ) gekikllt und schon waren alle anderen auch weg :)

Danke
Smoker

Smoker
06.02.2005, 15:25
dann schau mal nach ob es in der /etc/apache2/apach2.conf ein include dafür gibt
ich denke mal oder hoffe das suse da nicht wieder eigene suppe kocht

mfg

Diese Datei gibt es dort auch nicht.
Naja, der Reboot geht ja wieder normal :)

Was man vom Postfix und SMTP nicht sagen kann ;) :(

bye
Smoker