PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Safemod ... eigtlich aus, aber aber trozdem an ???



Smoker
09.11.2004, 10:46
Ich möchte meine Anhänge aus der DB in das Files system verschieben.
Nun sagt es mir, das das nicht geht, weil der Safemod an ist.

Nun steht in der php.ini aber drin ...

; Safe Mode
;
safe_mode = Off

Warum ist der dann an ???
Oder suche ich an der falschen stelle ???

Thxx
Smoker

Smoker
09.11.2004, 10:58
Ganz vergessen ... phpinfo sagt mir zu Safe Mod

Master value = Off
Local Value = On

Sehr komisch diese sache :(

Bin für jede Hilfe sehr dankbar.

bye
Smoker

Snatch
09.11.2004, 11:56
hast du Confixx am laufen ?

Holger
09.11.2004, 11:56
dann schau mal in die httpd.conf ;)

mfg

Smoker
09.11.2004, 12:23
Ja habe ich am laufen ( Confixx ).

Gut, da schaue ich mal in dieser datei nach :)

Thxx
Smoker

Holger
09.11.2004, 12:26
Confixx legt das 100% bei jedem virtual host an aber auch das läst sich abstellen
kann dir nur nicht genau sagen wo bin kein confixx nutzer
aber im zweifel kannst du ja den eintrag immer per hand ändern

mfg

Smoker
09.11.2004, 12:28
Jetzt bin ich wohl blind ... ich finde diese http.conf nicht.
Wo liegt die denn in den zich ordnern auf dem Server ?

Thxx
Smoker

Holger
09.11.2004, 12:31
ich finde diese http.conf nicht
ne ne nicht http.conf sondern httpd.conf liegt bei linux und apache meist unter /etc/

also vi /etc/httpd.conf

mfg

Smoker
09.11.2004, 12:40
War ein tippfehler :)
Ja unter etc ist sie, da hatte ich doch geschaut.
Man Man ich brauch echt ne neue Brille :D

Thxx
Smoker

Smoker
09.11.2004, 12:42
So habe nochmal geschaut ... dort ist diese datei einfach bei mir nicht.

Wenn ich im schell mit cd etc gehe ( dort ist ja auch die php.ini ) und eingebe ( edit httpd.conf ) will es eine neue datei mit diesem Namen erstellen :(

bye
Smoker

Holger
09.11.2004, 13:06
mach mal auf der shell "whereis httpd.conf" dann solltest du fündig werden
welche apache version hast du und welches os?
bei apache 2.... liegt die in /etc/apache2/httpd.conf


mfg

Smoker
09.11.2004, 13:21
Sorry musste kurz weg.

Also wenn ich das eingebe kommt das hier ...

/etc/httpd

Aber darin ist sie nicht.
Ist schon komisch :confused:
Denn ist apache2 und habe sie unter ( /etc/apache2 ) gefunden :)

Thxx
Smoker

Smoker
09.11.2004, 13:24
Ganz vergessen zu schreiben ... in der datei steht nix in sachen Safe Mod drin :(

Man Man jetzt habe ich eigentlich alles so wie ich es will und das macht jetzt solche Probs.:o

bye
Smoker

Holger
09.11.2004, 13:41
apache2 hat ja auch on mass include files
in irgendeinem steht das dort auch 100%
schau mal in

/etc/apache2/vhosts.d/vhosts.template
/etc/apache2/vhosts.d/default-server.conf

usw

mfg

Snatch
09.11.2004, 13:42
Confixx stellt dir das Mauel eingestellte immer wieder um.
Du musst das also so machen.

Safe mode off mußte über Confixx Adminlogin ändern:
Einstellungen -> Htpdspezial -> Kunde auswählen und das eintragen:


php_admin_value safe_mode off

Dann nen Haken bei:
für alle Domains des Kunden setzen und bei für alle Domains, die vom Kunden angelegt werden, setzen. Dann speichern und kurz warten bis Confixx die Datei neu geschrieben hat.


So einfach geht das ;)

Ps. niemals den Safe_Mode für die ganze IP abeschalten, da sonnt Confixx und einige andere Dinge nicht mehr gehen.

Smoker
09.11.2004, 14:18
Confixx stellt dir das Mauel eingestellte immer wieder um.
Du musst das also so machen.

Safe mode off mußte über Confixx Adminlogin ändern:
Einstellungen -> Htpdspezial -> Kunde auswählen und das eintragen:


php_admin_value safe_mode off

Dann nen Haken bei:
für alle Domains des Kunden setzen und bei für alle Domains, die vom Kunden angelegt werden, setzen. Dann speichern und kurz warten bis Confixx die Datei neu geschrieben hat.


So einfach geht das ;)

Ps. niemals den Safe_Mode für die ganze IP abeschalten, da sonnt Confixx und einige andere Dinge nicht mehr gehen.
Danke, hat wunderbar geklappt :)

bye
Smoker

Snatch
09.11.2004, 14:19
Danke, hat wunderbar geklappt :)

bye
Smoker
Ja sicher geht das, würde dir doch niemals Mist verzapfen hrhr.

Joe go
20.01.2005, 11:27
Hi
mein Safe mod is komischerweise seid kurzem (letzter neustart) auch wieder an!
nun in der php.ini ist er aus und in confixx hab ichs auch eingestellt aber.. safe mod is trotzdem noch an :-(
Hat einer einen kleinen ratschlag?

hier die infos:
datei hochladen:


file_uploads: An
open_basedir: /srv/www/htdocs/web1/
safe_mode: On
upload_tmp_dir: /srv/www/htdocs/web1/phptmp/
upload_max_filesize: 2M


php info:


safe_mode On Off
safe_mode_exec_dir /srv/www/htdocs/empty/ no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value

Local Value is on

hab noch das gefunden:

### CONFIXX APACHE VHOST FILE ####
### created Sun Jan 9 21:28:02 2005 ###

UseCanonicalName Off
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /srv/www/htdocs/empty/

is der flag safe_mode das gleiche wie der value safe_mode ?

Joe go
20.01.2005, 11:51
ok nach dem 2ten apache neustart hat ers angenommen :-)